Useful free utilities in Ubuntu for your day to day purpose

1) Zim, alternate to MS OneNote in Windows

Download Zim, available in Ubuntu Software Center

You can take your notes, create pages, add attachments, images and provides additional functionality like task list manager. I store and access my Zim note from dropbox, so you can access it from anywhere as long as you have Zim installed in that computer. Good news is Windows version of Zim is available.

zim,desktopwiki

2) Parcellite, Clipboard Manager

Download Parcellite, available in Ubuntu Software Center

A tool to preserve your history, by default 20 copied items are preserved in history. You can increase it to maximum with preferences option.

parcellite-preferences-history

3) BleachBit, alternate to CCleaner

Download BleachBit, available in Ubuntu Software Center

No much explanation is needed, we all love CCleaner and will miss it in Ubuntu. BleachBit provides similar solution in Ubuntu but not all features of CCleaner. Remember that your history items in Parcellite are still preserved and not deleted while cleaning with BleachBit.

bleachbit-clean

Cisco VPN Setup in Ubuntu

This document will help you configuring Cisco VPN Client in your Ubuntu computer.

1) In the Ubuntu Software Center, search and install “network-manager-gnome“.

2) Then, enable the option “Network management framework (VPNC plugin GNOME GUI)” in the same “network-manager-gnome” window and install it.

VPNC plugin GNOME GUI

2) Lets start configuring VPN in Network option available in the System Settings of Ubuntu (I assume you have all the required information from your VPN administrator!).

3) Click on “+” sign and choose interface as “VPN” to proceed.

ubuntu-cisco-vpn-configuration-1

4) Choose “Cisco Compatible VPN (vpnc)” when you see the below screen.

ubuntu-cisco-vpn-configuration-2

5) Specify your VPN settings and you have an option either to save or always ask for User / Group Password

Connection name name_it_as_you_like

Gateway is your_VPN_device_IP_address

User name is Login_User_Name

Group name is VPN_Group_Authentication_Name

ubuntu-cisco-vpn-configuration-3

6) In the advanced window, most likely you do not need to modify anything and leave it with default settings. Click Apply to complete the VPN configuration

ubuntu-cisco-vpn-configuration-4

7) Click on Network symbol on task bar (you will see a different icon if you are using a wired network connection, in my case my laptop is connected to a wireless network) and choose VPN Connections to establish connection to your corporate connection.

cisco-vpn-access-ubuntu

 

network-manager-gnome VPN Service failed to start

This may help some Ubuntu user !!!

I faced this strange issue while trying to connect to my corporate network via VPN on my Ubuntu PC – “VPN Service failed to start“. I tried all the possibilities mentioned in other forums and even unchecked “All Users may connect to this network” in network connections but still I was unable to connect VPN (by the way I am using network-manager-gnome Cisco VPN). Then I remember that I recently installed network driver for my wireless network card ralink – refer here, so I tried uninstalling and installing network-manager-gnome and it did the trick! so if you come across similar situation, give a try and let us know.

network-manager-gnome

Configure Cisco Router 887 FastEthernet port as WAN port

Scenario: Cisco 887 Router (4 LAN Ports) connected to an ISP Fiber Gateway Router HG8244T through one of its LAN port as WAN port.

Cisco887WANPort

You cannot directly set FastEthernet0-3 ports as Layer 3 ports or WAN, neither you can assign an IP address (“no switchport” will not work). In such case, create a VLAN interface with IP address and assign it to FastEthernet port, sample working configuration as below –

ip dhcp pool LANNW
network 10.1.1.0 255.255.255.0
default-router 10.1.1.254
dns-server 212.77.192.59 212.77.192.60
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
no ip address
shutdown
!
interface FastEthernet1
description **CONNECTED TO LANNW**
switchport access vlan 11
no ip address
spanning-tree portfast
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
description **CONNECTED TO WAN**
switchport access vlan 100
no ip address
spanning-tree portfast
!
interface Vlan1
no ip address
shutdown
!
interface Vlan11
description **CONNECTED TO LANNW**
ip address 10.1.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan100
description **CONNECTED TO WAN**
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
ip nat inside source list 101 interface Vlan100 overload
access-list 101 permit ip 10.1.1.0 0.0.0.255 any

Note: “ip routing” is enabled by default in Cisco router.

How to make Serial to USB Converter (Cable) work in Ubuntu

1. Get hardware address to which Serial-USB converter is attached

$ dmesg | grep tty

dmesg (display message or driver message) command is useful to gather hardware information loaded into kernel at the booting time or when a plug and play device is connected. You will get result something like below. Note down the port value, in my case it is ttyUSB0

usb 3-4: FTDI USB Serial Device converter now attached to ttyUSB0

2. Provide permission to this port

$ sudo chmod 666 /dev/ttyUSB0

You need to provide permission everytime you connect your serial-usb converter.

3. Try with Putty now to connect to your Serial device, it should work!